Övning.Domain

An NDoc Documented Class Library

Övning.Domain Namespace

Namespace hierarchy

Classes

Class | Description
Answer |
Category |
Country |
ErrorMessage | Corresponds with the table ERR in the system database
HelpMessage |
License |
LogEntry | Corresponds with the database table HCK
Organisation | An organisation organizes wargames
PasswordQuestion | PasswordQuestions are can be answered to retrieve ones password. At registration a question can be selected, and an answer given. Later he same answer will need to be given to retrieve ones password.
Question | Questions can exist on their own or be part of a Survey. When a Question is deleted all corresponding Questions will be removed from surveys that contained it.
QuestionType | Corresponds with the CTL table in the organisation database
Rank |
SecurityHandler |
Status | Defines the status of a user: Active or Revoked.
Survey | A survey has a couple of questions and belongs to a wargame
User | Corresponds with the USR table in the database


Answer Class

For a list of all members of this type, see Answer Members.

System.Object
PersistentObject
OrganisationBoundPersistentObject
Answer

public class Answer : OrganisationBoundPersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

Answer Members | Övning.Domain Namespace


Answers Property

An NDoc Documented Class Library

Answer.Answers Property

public Answers {get; set;}

See Also

Answer Class | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

Answer.Identifier Property

public Identifier {get; set;}

See Also

Answer Class | Övning.Domain Namespace


Participant Property

An NDoc Documented Class Library

Answer.Participant Property

public Participant {get; set;}

See Also

Answer Class | Övning.Domain Namespace


ParticipantId Property

An NDoc Documented Class Library

Answer.ParticipantId Property

public ParticipantId {get; set;}

See Also

Answer Class | Övning.Domain Namespace


Question Property

An NDoc Documented Class Library

Answer.Question Property

public Question {get; set;}

See Also

Answer Class | Övning.Domain Namespace


QuestionId Property

An NDoc Documented Class Library

Answer.QuestionId Property

public QuestionId {get; set;}

See Also

Answer Class | Övning.Domain Namespace


Answer.Read Method

public static Answer Read(
Survey survey,
Question question,
Participant user
);

See Also

Answer Class | Övning.Domain Namespace


Answer.ReadAllBySurvey Method

public static IList<T> ReadAllBySurvey(
Survey survey
);

See Also

Answer Class | Övning.Domain Namespace


Answer.ReadAllBySurveyAndQuestion Method

public static IList<T> ReadAllBySurveyAndQuestion(
Survey survey
);

See Also

Answer Class | Övning.Domain Namespace


Answer.ReadAllBySurveyAndUser Method

public static IList<T> ReadAllBySurveyAndUser(
Survey survey,
Participant user
);

See Also

Answer Class | Övning.Domain Namespace


Answer.Save Method

public static void Save(
Survey mySurvey,
Question myQuestion,
Participant myParticipant,
IList<T> myAnswers
);

See Also

Answer Class | Övning.Domain Namespace


Survey Property

An NDoc Documented Class Library

Answer.Survey Property

public Survey {get; set;}

See Also

Answer Class | Övning.Domain Namespace


SurveyId Property

An NDoc Documented Class Library

Answer.SurveyId Property

public SurveyId {get; set;}

See Also

Answer Class | Övning.Domain Namespace


Text Property

An NDoc Documented Class Library

Answer.Text Property

public Text {get; set;}

See Also

Answer Class | Övning.Domain Namespace


Answer Constructor

Initializes a new instance of the Answer class.

public Answer();

See Also

Answer Class | Övning.Domain Namespace


Answer Members

Answer overview

Public Static Methods

Read
ReadAllBySurvey
ReadAllBySurveyAndQuestion
ReadAllBySurveyAndUser
Save

Public Instance Constructors

Answer Constructor Initializes a new instance of the Answer class.

Public Instance Properties

Answers
Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Participant
ParticipantId
Question
QuestionId
Survey
SurveyId
Text

Public Instance Methods

Create (inherited from OrganisationBoundPersistentObject) |
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Answer Class | Övning.Domain Namespace


Answer Methods

The methods of the Answer class are listed below. For a complete list of Answer class members, see the Answer Members topic.

Public Static Methods

Read
ReadAllBySurvey
ReadAllBySurveyAndQuestion
ReadAllBySurveyAndUser
Save

Public Instance Methods

Create (inherited from OrganisationBoundPersistentObject) |
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Answer Class | Övning.Domain Namespace


Answer Properties

The properties of the Answer class are listed below. For a complete list of Answer class members, see the Answer Members topic.

Public Instance Properties

Answers
Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Participant
ParticipantId
Question
QuestionId
Survey
SurveyId
Text

See Also

Answer Class | Övning.Domain Namespace


Category Class

For a list of all members of this type, see Category Members.

System.Object
PersistentObject
OrganisationBoundPersistentObject
Category

public class Category : OrganisationBoundPersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

Category Members | Övning.Domain Namespace


Comments Property

An NDoc Documented Class Library

Category.Comments Property

public Comments {get; set;}

See Also

Category Class | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

Category.Identifier Property

public Identifier {get; set;}

See Also

Category Class | Övning.Domain Namespace


Name Property

An NDoc Documented Class Library

Category.Name Property

public Name {get; set;}

See Also

Category Class | Övning.Domain Namespace


Category.Read Method

public static Category Read(
Int32 identifier
);

See Also

Category Class | Övning.Domain Namespace


Category.ReadAll Method

new public static IList<T> ReadAll();

See Also

Category Class | Övning.Domain Namespace


Category Constructor

Initializes a new instance of the Category class.

public Category();

See Also

Category Class | Övning.Domain Namespace


Category Members

Category overview

Public Static Methods

Read
ReadAll

Public Instance Constructors

Category Constructor Initializes a new instance of the Category class.

Public Instance Properties

Comments
Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Name

Public Instance Methods

Create (inherited from OrganisationBoundPersistentObject) |
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Category Class | Övning.Domain Namespace


Category Methods

The methods of the Category class are listed below. For a complete list of Category class members, see the Category Members topic.

Public Static Methods

Read
ReadAll

Public Instance Methods

Create (inherited from OrganisationBoundPersistentObject) |
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Category Class | Övning.Domain Namespace


Category Properties

The properties of the Category class are listed below. For a complete list of Category class members, see the Category Members topic.

Public Instance Properties

Comments
Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Name

See Also

Category Class | Övning.Domain Namespace


Country Class

For a list of all members of this type, see Country Members.

System.Object
PersistentObject
Country

public class Country : PersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

Country Members | Övning.Domain Namespace


Country.Create Method

public override int Create();

See Also

Country Class | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

Country.Identifier Property

public Identifier {get; set;}

See Also

Country Class | Övning.Domain Namespace


Name Property

An NDoc Documented Class Library

Country.Name Property

public Name {get; set;}

See Also

Country Class | Övning.Domain Namespace


Country.Read Method

public static Country Read(
Int32 identifier
);

See Also

Country Class | Övning.Domain Namespace


Country.ReadAll Method

new public static IList<T> ReadAll();

See Also

Country Class | Övning.Domain Namespace


Country Constructor

Initializes a new instance of the Country class.

public Country();

See Also

Country Class | Övning.Domain Namespace


Country Members

Country overview

Public Static Methods

Read
ReadAll

Public Instance Constructors

Country Constructor Initializes a new instance of the Country class.

Public Instance Properties

Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Name

Public Instance Methods

Create |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Country Class | Övning.Domain Namespace


Country Methods

The methods of the Country class are listed below. For a complete list of Country class members, see the Country Members topic.

Public Static Methods

Read
ReadAll

Public Instance Methods

Create |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Country Class | Övning.Domain Namespace


Country Properties

The properties of the Country class are listed below. For a complete list of Country class members, see the Country Members topic.

Public Instance Properties

Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Name

See Also

Country Class | Övning.Domain Namespace


ErrorMessage Class

Corresponds with the table ERR in the system database

For a list of all members of this type, see ErrorMessage Members.

System.Object
PersistentObject
ErrorMessage

public class ErrorMessage : PersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

ErrorMessage Members | Övning.Domain Namespace


Description Property

An NDoc Documented Class Library

ErrorMessage.Description Property

The message itself

public Description {get; set;}

Remarks

See Also

ErrorMessage Class | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

ErrorMessage.Identifier Property

Unique Identifier. Is autogenerated when inserting a new Errormsg into the database

public Identifier {get; set;}

Remarks

See Also

ErrorMessage Class | Övning.Domain Namespace


Name Property

An NDoc Documented Class Library

ErrorMessage.Name Property

Name of the ErrorMsg

public Name {get; set;}

Remarks

See Also

ErrorMessage Class | Övning.Domain Namespace


ErrorMessage.Read Method

Reads a specific ErrorMsg from the database

public static ErrorMessage Read(
Int32 identifier
);

Parameters

Int32
key of the ErrorMsg

Return Value

Remarks

See Also

ErrorMessage Class | Övning.Domain Namespace


ErrorMessage.ReadAll Method

Reads all Errormessages from the database

new public static IList<T> ReadAll();

Return Value

IList(Of ErrorMsg)

Remarks

See Also

ErrorMessage Class | Övning.Domain Namespace


WrongPassword Property

An NDoc Documented Class Library

ErrorMessage.WrongPassword Property

public static WrongPassword {get;}

See Also

ErrorMessage Class | Övning.Domain Namespace


WrongUserName Property

An NDoc Documented Class Library

ErrorMessage.WrongUserName Property

public static WrongUserName {get;}

See Also

ErrorMessage Class | Övning.Domain Namespace


ErrorMessage Constructor

Initializes a new instance of the ErrorMessage class.

public ErrorMessage();

See Also

ErrorMessage Class | Övning.Domain Namespace


ErrorMessage Members

ErrorMessage overview

Public Static Properties

WrongPassword
WrongUserName

Public Static Methods

Read | Reads a specific ErrorMsg from the database
ReadAll | Reads all Errormessages from the database

Public Instance Constructors

ErrorMessage Constructor Initializes a new instance of the ErrorMessage class.

Public Instance Properties

Description | The message itself
Identifier | Unique Identifier. Is autogenerated when inserting a new Errormsg into the database
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | Name of the ErrorMsg

Public Instance Methods

Create (inherited from Övning.Data.Util.PersistentObject) |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

ErrorMessage Class | Övning.Domain Namespace


ErrorMessage Methods

The methods of the ErrorMessage class are listed below. For a complete list of ErrorMessage class members, see the ErrorMessage Members topic.

Public Static Methods

Read | Reads a specific ErrorMsg from the database
ReadAll | Reads all Errormessages from the database

Public Instance Methods

Create (inherited from Övning.Data.Util.PersistentObject) |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

ErrorMessage Class | Övning.Domain Namespace


ErrorMessage Properties

The properties of the ErrorMessage class are listed below. For a complete list of ErrorMessage class members, see the ErrorMessage Members topic.

Public Static Properties

WrongPassword
WrongUserName

Public Instance Properties

Description | The message itself
Identifier | Unique Identifier. Is autogenerated when inserting a new Errormsg into the database
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | Name of the ErrorMsg

See Also

ErrorMessage Class | Övning.Domain Namespace


Övning.Domain.Game

An NDoc Documented Class Library

Övning.Domain.Game Namespace

Namespace hierarchy

Classes

Class | Description
Document | Document that accompanies a Wargame. Possible documents are: Framework, Rules, Goals, Lodging....
DocumentType | DocumentType is the type of a document
Participant | A Participant is a User that participates in a Wargame
ParticipantRole | ParticipantRole is the role a Participant can have within a Wargame.
WarGame | This class is responsible for the data of a single wargame.
WarGameStatus |


Document Class

Document that accompanies a Wargame. Possible documents are: Framework, Rules, Goals, Lodging....

For a list of all members of this type, see Document Members.

System.Object
PersistentObject
OrganisationBoundPersistentObject
Document

public class Document : OrganisationBoundPersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Corresponds with the DOC table in the organisationdatabase

Requirements

Namespace: Övning.Domain.Game

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

Document Members | Övning.Domain.Game Namespace


Document.Create Method

Inserts a new Document into the database and sets its identifier with the newly created one

public override int Create();

Return Value

Integer

See Also

Document Class | Övning.Domain.Game Namespace


DocType Property

An NDoc Documented Class Library

Document.DocType Property

DocumentType of this Document

public DocType {get; set;}

Property Value

Remarks

See Also

Document Class | Övning.Domain.Game Namespace


DocTypeId Property

An NDoc Documented Class Library

Document.DocTypeId Property

Identifier of the DocumentType of this Document

public DocTypeId {get; set;}

See Also

Document Class | Övning.Domain.Game Namespace


File Property

An NDoc Documented Class Library

Document.File Property

public File {get; set;}

See Also

Document Class | Övning.Domain.Game Namespace


Identifier Property

An NDoc Documented Class Library

Document.Identifier Property

Unique identifier of the Document. Automatically generated when a new Document is inserted into the database

public Identifier {get; set;}

See Also

Document Class | Övning.Domain.Game Namespace


Document.Read Method

Reads a specific document from the database

public static Document Read(
Int32 identifier
);

Parameters

Int32
Identifier of the document

Return Value

Document

See Also

Document Class | Övning.Domain.Game Namespace


Document.ReadAll Method

Reads all Documents from the database

new public static IList<T> ReadAll();

Return Value

IList(Of Document)

See Also

Document Class | Övning.Domain.Game Namespace


Document.ReadByWargameId Method

Reads all Documents for a specific Wargame from the database

public static IList<T> ReadByWargameId(
Int32 wargameId
);

Parameters

Int32
Identifier of the Wargame the documents should belong to

Return Value

IList(Of Document)

See Also

Document Class | Övning.Domain.Game Namespace


Text Property

An NDoc Documented Class Library

Document.Text Property

Body of the document. All text goes here

public Text {get; set;}

See Also

Document Class | Övning.Domain.Game Namespace


Title Property

An NDoc Documented Class Library

Document.Title Property

Title of the document

public Title {get; set;}

See Also

Document Class | Övning.Domain.Game Namespace


Wargame Property

An NDoc Documented Class Library

Document.Wargame Property

Wargame this Document belongs to.

public Wargame {get; set;}

See Also

Document Class | Övning.Domain.Game Namespace


WargameId Property

An NDoc Documented Class Library

Document.WargameId Property

Identifier of the Wargame this document belongs with.

public WargameId {get; set;}

See Also

Document Class | Övning.Domain.Game Namespace


Document Constructor

Initializes a new instance of the Document class.

public Document();

See Also

Document Class | Övning.Domain.Game Namespace


Document Members

Document overview

Public Static Methods

Read | Reads a specific document from the database
ReadAll | Reads all Documents from the database
ReadByWargameId | Reads all Documents for a specific Wargame from the database

Public Instance Constructors

Document Constructor Initializes a new instance of the Document class.

Public Instance Properties

DocType | DocumentType of this Document
DocTypeId | Identifier of the DocumentType of this Document
File |
Identifier | Unique identifier of the Document. Automatically generated when a new Document is inserted into the database
Map (inherited from Övning.Data.Util.PersistentObject) |
Text | Body of the document. All text goes here
Title | Title of the document
Wargame | Wargame this Document belongs to.
WargameId | Identifier of the Wargame this document belongs with.

Public Instance Methods

Create | Inserts a new Document into the database and sets its identifier with the newly created one
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Document Class | Övning.Domain.Game Namespace


Document Methods

The methods of the Document class are listed below. For a complete list of Document class members, see the Document Members topic.

Public Static Methods

Read | Reads a specific document from the database
ReadAll | Reads all Documents from the database
ReadByWargameId | Reads all Documents for a specific Wargame from the database

Public Instance Methods

Create | Inserts a new Document into the database and sets its identifier with the newly created one
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Document Class | Övning.Domain.Game Namespace


Document Properties

The properties of the Document class are listed below. For a complete list of Document class members, see the Document Members topic.

Public Instance Properties

DocType | DocumentType of this Document
DocTypeId | Identifier of the DocumentType of this Document
File |
Identifier | Unique identifier of the Document. Automatically generated when a new Document is inserted into the database
Map (inherited from Övning.Data.Util.PersistentObject) |
Text | Body of the document. All text goes here
Title | Title of the document
Wargame | Wargame this Document belongs to.
WargameId | Identifier of the Wargame this document belongs with.

See Also

Document Class | Övning.Domain.Game Namespace


DocumentType Class

DocumentType is the type of a document

For a list of all members of this type, see DocumentType Members.

System.Object
PersistentObject
OrganisationBoundPersistentObject
DocumentType

public class DocumentType : OrganisationBoundPersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Corresponds with the DOCTYPE table in the organisation database.

Requirements

Namespace: Övning.Domain.Game

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

DocumentType Members | Övning.Domain.Game Namespace


Identifier Property

An NDoc Documented Class Library

DocumentType.Identifier Property

Unique Identifier of the Documenttype. Automatically generated when a new DocumentType is inserted into the database. This should never happen

public Identifier {get; set;}

See Also

DocumentType Class | Övning.Domain.Game Namespace


Name Property

An NDoc Documented Class Library

DocumentType.Name Property

Name of the documentType

public Name {get; set;}

See Also

DocumentType Class | Övning.Domain.Game Namespace


DocumentType.Read Method

Reads a specific DocumentType from the cached list of DocumentTypes

public static DocumentType Read(
Int32 identifier
);

Parameters

Int32
Identifier of the DocumentType to read

Return Value

DocumentType

See Also

DocumentType Class | Övning.Domain.Game Namespace


DocumentType.ReadAll Method

Reads all DocumentTypes from the database and caches them. All future ReadAll() requests will return the cached list.

new public static IList<T> ReadAll();

Return Value

IList(Of DocumentType)

See Also

DocumentType Class | Övning.Domain.Game Namespace


DocumentType Constructor

Initializes a new instance of the DocumentType class.

public DocumentType();

See Also

DocumentType Class | Övning.Domain.Game Namespace


DocumentType Members

DocumentType overview

Public Static Methods

Read | Reads a specific DocumentType from the cached list of DocumentTypes
ReadAll | Reads all DocumentTypes from the database and caches them. All future ReadAll() requests will return the cached list.

Public Instance Constructors

DocumentType Constructor Initializes a new instance of the DocumentType class.

Public Instance Properties

Identifier | Unique Identifier of the Documenttype. Automatically generated when a new DocumentType is inserted into the database. This should never happen
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | Name of the documentType

Public Instance Methods

Create (inherited from OrganisationBoundPersistentObject) |
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

DocumentType Class | Övning.Domain.Game Namespace


DocumentType Methods

The methods of the DocumentType class are listed below. For a complete list of DocumentType class members, see the DocumentType Members topic.

Public Static Methods

Read | Reads a specific DocumentType from the cached list of DocumentTypes
ReadAll | Reads all DocumentTypes from the database and caches them. All future ReadAll() requests will return the cached list.

Public Instance Methods

Create (inherited from OrganisationBoundPersistentObject) |
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

DocumentType Class | Övning.Domain.Game Namespace


DocumentType Properties

The properties of the DocumentType class are listed below. For a complete list of DocumentType class members, see the DocumentType Members topic.

Public Instance Properties

Identifier | Unique Identifier of the Documenttype. Automatically generated when a new DocumentType is inserted into the database. This should never happen
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | Name of the documentType

See Also

DocumentType Class | Övning.Domain.Game Namespace


Participant Class

A Participant is a User that participates in a Wargame

For a list of all members of this type, see Participant Members.

System.Object
PersistentObject
OrganisationBoundPersistentObject
Participant

public class Participant : OrganisationBoundPersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Corresponds with the GUR table in the organisationdatabase.

Requirements

Namespace: Övning.Domain.Game

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

Participant Members | Övning.Domain.Game Namespace


Participant.Create Method

Inserts a new Participant into the database and sets its identifier with the newly created key.

public override int Create();

Return Value

Integer

See Also

Participant Class | Övning.Domain.Game Namespace


Participant.FindCurrentParticipantFor Method

public static Participant FindCurrentParticipantFor(
Int32 warGameIdentifier
);

See Also

Participant Class | Övning.Domain.Game Namespace


Identifier Property

An NDoc Documented Class Library

Participant.Identifier Property

Unique Identifier, Autogenerated when a new Participant is inserted into the database.

public Identifier {get; set;}

See Also

Participant Class | Övning.Domain.Game Namespace


Participant.Read Method

Reads a specific Participant from the database

public static Participant Read(
Int32 identifier
);

Parameters

Int32
Identifier of the Participant

Return Value

Participant

See Also

Participant Class | Övning.Domain.Game Namespace


Participant.ReadAll Method

Reads all Participants from the given Wargame from the database

public static IList<T> ReadAll(
Int32 warGameIdentifier
);

Parameters

Int32
Identifier of the Wargame

Return Value

IList(Of Participant)

See Also

Participant Class | Övning.Domain.Game Namespace


RoleIdentifier Property

An NDoc Documented Class Library

Participant.RoleIdentifier Property

Identifier of the Role that this Participant has in the Wargame.

public RoleIdentifier {get; set;}

See Also

Participant Class | Övning.Domain.Game Namespace


User Property

An NDoc Documented Class Library

Participant.User Property

User that corresponds with this Participant.

public User {get; set;}

Remarks

Use UserIdentifier() to set its identifier

See Also

Participant Class | Övning.Domain.Game Namespace


UserIdentifier Property

An NDoc Documented Class Library

Participant.UserIdentifier Property

Identifier of the User that this Participant corresponds with

public UserIdentifier {get; set;}

See Also

Participant Class | Övning.Domain.Game Namespace


UserName Property

An NDoc Documented Class Library

Participant.UserName Property

Username of the Participant

public UserName {get;}

Remarks

Readonly

See Also

Participant Class | Övning.Domain.Game Namespace


WarGameIdentifier Property

An NDoc Documented Class Library

Participant.WarGameIdentifier Property

Identifier of the Wargame this Participant participates in.

public WarGameIdentifier {get; set;}

See Also

Participant Class | Övning.Domain.Game Namespace


Participant Constructor

Initializes a new instance of the Participant class.

public Participant();

See Also

Participant Class | Övning.Domain.Game Namespace


Participant Members

Participant overview

Public Static Methods

FindCurrentParticipantFor |
Read | Reads a specific Participant from the database
ReadAll | Reads all Participants from the given Wargame from the database

Public Instance Constructors

Participant Constructor Initializes a new instance of the Participant class.

Public Instance Properties

Identifier | Unique Identifier, Autogenerated when a new Participant is inserted into the database.
Map (inherited from Övning.Data.Util.PersistentObject) |
RoleIdentifier | Identifier of the Role that this Participant has in the Wargame.
User | User that corresponds with this Participant.
UserIdentifier | Identifier of the User that this Participant corresponds with
UserName | Username of the Participant
WarGameIdentifier | Identifier of the Wargame this Participant participates in.

Public Instance Methods

Create | Inserts a new Participant into the database and sets its identifier with the newly created key.
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Participant Class | Övning.Domain.Game Namespace


Participant Methods

The methods of the Participant class are listed below. For a complete list of Participant class members, see the Participant Members topic.

Public Static Methods

FindCurrentParticipantFor |
Read | Reads a specific Participant from the database
ReadAll | Reads all Participants from the given Wargame from the database

Public Instance Methods

Create | Inserts a new Participant into the database and sets its identifier with the newly created key.
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Participant Class | Övning.Domain.Game Namespace


Participant Properties

The properties of the Participant class are listed below. For a complete list of Participant class members, see the Participant Members topic.

Public Instance Properties

Identifier | Unique Identifier, Autogenerated when a new Participant is inserted into the database.
Map (inherited from Övning.Data.Util.PersistentObject) |
RoleIdentifier | Identifier of the Role that this Participant has in the Wargame.
User | User that corresponds with this Participant.
UserIdentifier | Identifier of the User that this Participant corresponds with
UserName | Username of the Participant
WarGameIdentifier | Identifier of the Wargame this Participant participates in.

See Also

Participant Class | Övning.Domain.Game Namespace


ParticipantRole Class

ParticipantRole is the role a Participant can have within a Wargame.

For a list of all members of this type, see ParticipantRole Members.

System.Object
PersistentObject
OrganisationBoundPersistentObject
ParticipantRole

public class ParticipantRole : OrganisationBoundPersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Corresponds with table ROL in the organisationdatabase

Requirements

Namespace: Övning.Domain.Game

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

ParticipantRole Members | Övning.Domain.Game Namespace


Comment Property

An NDoc Documented Class Library

ParticipantRole.Comment Property

Comments about the role (eg. what should this role do, what shouldn't it do...)

public Comment {get; set;}

See Also

ParticipantRole Class | Övning.Domain.Game Namespace


ParticipantRole.Create Method

public override int Create();

See Also

ParticipantRole Class | Övning.Domain.Game Namespace


Identifier Property

An NDoc Documented Class Library

ParticipantRole.Identifier Property

Unique identifier.

public Identifier {get; set;}

Property Value

Remarks

See Also

ParticipantRole Class | Övning.Domain.Game Namespace


Name Property

An NDoc Documented Class Library

ParticipantRole.Name Property

Name of the role

public Name {get; set;}

Remarks

Currently available roles: Manager, Mentor, Conter player, Internal participant, External participant

See Also

ParticipantRole Class | Övning.Domain.Game Namespace


ParticipantRole.Read Method

Reads a specific ParticipantRole from the cached list of ParticipantRoles

public static ParticipantRole Read(
Int32 identifier
);

Parameters

Int32
Identifier of the ParticipantRole

Return Value

ParticipantRole

See Also

ParticipantRole Class | Övning.Domain.Game Namespace


ParticipantRole.ReadAll Method

Reads all ParticipantRoles from the database and caches the result

new public static IList<T> ReadAll();

Return Value

IList(Of ParticipantRole)

Remarks

When new ParticipantRoles are added to the database the application will have to be restarted

See Also

ParticipantRole Class | Övning.Domain.Game Namespace


ParticipantRole Constructor

Initializes a new instance of the ParticipantRole class.

public ParticipantRole();

See Also

ParticipantRole Class | Övning.Domain.Game Namespace


ParticipantRole Members

ParticipantRole overview

Public Static Methods

Read | Reads a specific ParticipantRole from the cached list of ParticipantRoles
ReadAll | Reads all ParticipantRoles from the database and caches the result

Public Instance Constructors

ParticipantRole Constructor Initializes a new instance of the ParticipantRole class.

Public Instance Properties

Comment | Comments about the role (eg. what should this role do, what shouldn't it do...)
Identifier | Unique identifier.
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | Name of the role

Public Instance Methods

Create |
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

ParticipantRole Class | Övning.Domain.Game Namespace


ParticipantRole Methods

The methods of the ParticipantRole class are listed below. For a complete list of ParticipantRole class members, see the ParticipantRole Members topic.

Public Static Methods

Read | Reads a specific ParticipantRole from the cached list of ParticipantRoles
ReadAll | Reads all ParticipantRoles from the database and caches the result

Public Instance Methods

Create |
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

ParticipantRole Class | Övning.Domain.Game Namespace


ParticipantRole Properties

The properties of the ParticipantRole class are listed below. For a complete list of ParticipantRole class members, see the ParticipantRole Members topic.

Public Instance Properties

Comment | Comments about the role (eg. what should this role do, what shouldn't it do...)
Identifier | Unique identifier.
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | Name of the role

See Also

ParticipantRole Class | Övning.Domain.Game Namespace


WarGame Class

This class is responsible for the data of a single wargame.

For a list of all members of this type, see WarGame Members.

System.Object
PersistentObject
OrganisationBoundPersistentObject
WarGame

public class WarGame : OrganisationBoundPersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Corresponds with the GAM table in the organisationdatabase

Requirements

Namespace: Övning.Domain.Game

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

WarGame Members | Övning.Domain.Game Namespace


WarGame.Create Method

Creates a new WarGame with Status 1 this schoud be changed!!

public override int Create();

Return Value

The identifier of the new WarGame

See Also

WarGame Class | Övning.Domain.Game Namespace


Documents Property

An NDoc Documented Class Library

WarGame.Documents Property

public Documents {get;}

See Also

WarGame Class | Övning.Domain.Game Namespace


Identifier Property

An NDoc Documented Class Library

WarGame.Identifier Property

Unique Identifier of the Wargame. When a new Wargame is inserted into the database this is automagically generated

public Identifier {get; set;}

See Also

WarGame Class | Övning.Domain.Game Namespace


Name Property

An NDoc Documented Class Library

WarGame.Name Property

A wargame has a name

public Name {get; set;}

Remarks

unique within an organisation

See Also

WarGame Class | Övning.Domain.Game Namespace


Participants Property

An NDoc Documented Class Library

WarGame.Participants Property

public Participants {get;}

See Also

WarGame Class | Övning.Domain.Game Namespace


WarGame.Read Method

public static WarGame Read(
Int32 identifier
);

See Also

WarGame Class | Övning.Domain.Game Namespace


WarGame.ReadAll Method

new public static IList<T> ReadAll();

See Also

WarGame Class | Övning.Domain.Game Namespace


WarGame.ReadAllWarGamesForCurrentUser Method

public static IList<T> ReadAllWarGamesForCurrentUser();

See Also

WarGame Class | Övning.Domain.Game Namespace


Start Property

An NDoc Documented Class Library

WarGame.Start Property

A wargame starts at a certain time and date

public Start {get; set;}

Property Value

Remarks

See Also

WarGame Class | Övning.Domain.Game Namespace


Status Property

An NDoc Documented Class Library

WarGame.Status Property

public Status {get; set;}

See Also

WarGame Class | Övning.Domain.Game Namespace


StatusIdentifier Property

An NDoc Documented Class Library

WarGame.StatusIdentifier Property

public StatusIdentifier {get; set;}

See Also

WarGame Class | Övning.Domain.Game Namespace


Surveys Property

An NDoc Documented Class Library

WarGame.Surveys Property

public Surveys {get;}

See Also

WarGame Class | Övning.Domain.Game Namespace


UsersNotInWarGame Property

An NDoc Documented Class Library

WarGame.UsersNotInWarGame Property

Returns all the users in the organisation that are not participating in this War Game.

public UsersNotInWarGame {get;}

See Also

WarGame Class | Övning.Domain.Game Namespace


WarGame Constructor

Initializes a new instance of the WarGame class.

public WarGame();

See Also

WarGame Class | Övning.Domain.Game Namespace


WarGame Members

WarGame overview

Public Static Methods

Read
ReadAll
ReadAllWarGamesForCurrentUser

Public Instance Constructors

WarGame Constructor Initializes a new instance of the WarGame class.

Public Instance Properties

Documents |
Identifier | Unique Identifier of the Wargame. When a new Wargame is inserted into the database this is automagically generated
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | A wargame has a name
Participants |
Start | A wargame starts at a certain time and date
Status |
StatusIdentifier |
Surveys |
UsersNotInWarGame | Returns all the users in the organisation that are not participating in this War Game.

Public Instance Methods

Create | Creates a new WarGame with Status 1 this schoud be changed!!
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

WarGame Class | Övning.Domain.Game Namespace


WarGame Methods

The methods of the WarGame class are listed below. For a complete list of WarGame class members, see the WarGame Members topic.

Public Static Methods

Read
ReadAll
ReadAllWarGamesForCurrentUser

Public Instance Methods

Create | Creates a new WarGame with Status 1 this schoud be changed!!
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

WarGame Class | Övning.Domain.Game Namespace


WarGame Properties

The properties of the WarGame class are listed below. For a complete list of WarGame class members, see the WarGame Members topic.

Public Instance Properties

Documents |
Identifier | Unique Identifier of the Wargame. When a new Wargame is inserted into the database this is automagically generated
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | A wargame has a name
Participants |
Start | A wargame starts at a certain time and date
Status |
StatusIdentifier |
Surveys |
UsersNotInWarGame | Returns all the users in the organisation that are not participating in this War Game.

See Also

WarGame Class | Övning.Domain.Game Namespace


WarGameStatus Class

For a list of all members of this type, see WarGameStatus Members.

System.Object
PersistentObject
OrganisationBoundPersistentObject
WarGameStatus

public class WarGameStatus : OrganisationBoundPersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain.Game

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

WarGameStatus Members | Övning.Domain.Game Namespace


CreatedStatus Property

An NDoc Documented Class Library

WarGameStatus.CreatedStatus Property

public static CreatedStatus {get;}

See Also

WarGameStatus Class | Övning.Domain.Game Namespace


Identifier Property

An NDoc Documented Class Library

WarGameStatus.Identifier Property

public Identifier {get; set;}

See Also

WarGameStatus Class | Övning.Domain.Game Namespace


Name Property

An NDoc Documented Class Library

WarGameStatus.Name Property

public Name {get; set;}

See Also

WarGameStatus Class | Övning.Domain.Game Namespace


WarGameStatus.Read Method

public static WarGameStatus Read(
Int32 identifier
);

See Also

WarGameStatus Class | Övning.Domain.Game Namespace


WarGameStatus.ReadAll Method

new public static IList<T> ReadAll();

See Also

WarGameStatus Class | Övning.Domain.Game Namespace


WarGameStatus Constructor

Initializes a new instance of the WarGameStatus class.

public WarGameStatus();

See Also

WarGameStatus Class | Övning.Domain.Game Namespace


WarGameStatus Members

WarGameStatus overview

Public Static Properties

CreatedStatus

Public Static Methods

Read
ReadAll

Public Instance Constructors

WarGameStatus Constructor Initializes a new instance of the WarGameStatus class.

Public Instance Properties

Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Name

Public Instance Methods

Create (inherited from OrganisationBoundPersistentObject) |
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

WarGameStatus Class | Övning.Domain.Game Namespace


WarGameStatus Methods

The methods of the WarGameStatus class are listed below. For a complete list of WarGameStatus class members, see the WarGameStatus Members topic.

Public Static Methods

Read
ReadAll

Public Instance Methods

Create (inherited from OrganisationBoundPersistentObject) |
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

WarGameStatus Class | Övning.Domain.Game Namespace


WarGameStatus Properties

The properties of the WarGameStatus class are listed below. For a complete list of WarGameStatus class members, see the WarGameStatus Members topic.

Public Static Properties

CreatedStatus

Public Instance Properties

Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Name

See Also

WarGameStatus Class | Övning.Domain.Game Namespace


Hierarchy

System.Object
Övning.Data.Util.PersistentObject
Övning.Domain.Util.OrganisationBoundPersistentObject
Övning.Domain.Game.Document
Övning.Domain.Game.DocumentType
Övning.Domain.Game.Participant
Övning.Domain.Game.ParticipantRole
Övning.Domain.Game.WarGame
Övning.Domain.Game.WarGameStatus

See Also

Övning.Domain.Game Namespace


HelpMessage Class

For a list of all members of this type, see HelpMessage Members.

System.Object
PersistentObject
HelpMessage

public class HelpMessage : PersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

HelpMessage Members | Övning.Domain Namespace


CultureCode Property

An NDoc Documented Class Library

HelpMessage.CultureCode Property

public CultureCode {get; set;}

See Also

HelpMessage Class | Övning.Domain Namespace


HelpMessage.FetchMessage Method (String)

public static string FetchMessage(
String key
);

See Also

HelpMessage Class | Övning.Domain Namespace | HelpMessage.FetchMessage Overload List


HelpMessage.FetchMessage Method (String, String)

public static string FetchMessage(
String key,
String cultureCode
);

See Also

HelpMessage Class | Övning.Domain Namespace | HelpMessage.FetchMessage Overload List


FetchMessage Method

An NDoc Documented Class Library

HelpMessage.FetchMessage Method

Overload List

public static string FetchMessage(String);

public static string FetchMessage(String,String);

See Also

HelpMessage Class | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

HelpMessage.Identifier Property

public Identifier {get; set;}

See Also

HelpMessage Class | Övning.Domain Namespace


Message Property

An NDoc Documented Class Library

HelpMessage.Message Property

public Message {get; set;}

See Also

HelpMessage Class | Övning.Domain Namespace


HelpMessage.Read Method

public static HelpMessage Read(
String key,
String cultureCode
);

See Also

HelpMessage Class | Övning.Domain Namespace


HelpMessage.ReadAll Method

new public static IList<T> ReadAll();

See Also

HelpMessage Class | Övning.Domain Namespace


HelpMessage.Update Method (HelpMessage)

public static void Update(
HelpMessage helpMessageToUpdate
);

See Also

HelpMessage Class | Övning.Domain Namespace | HelpMessage.Update Overload List


Update Method

An NDoc Documented Class Library

HelpMessage.Update Method

Overload List

Inherited from PersistentObject.

public virtual void Update();

public static void Update(HelpMessage);

See Also

HelpMessage Class | Övning.Domain Namespace


HelpMessage.UpdateOrCreate Method

public static void UpdateOrCreate(
String key,
String cultureCode,
String message
);

See Also

HelpMessage Class | Övning.Domain Namespace


Url Property

An NDoc Documented Class Library

HelpMessage.Url Property

public Url {get; set;}

See Also

HelpMessage Class | Övning.Domain Namespace


HelpMessage Constructor

Initializes a new instance of the HelpMessage class.

public HelpMessage();

See Also

HelpMessage Class | Övning.Domain Namespace


HelpMessage Members

HelpMessage overview

Public Static Methods

FetchMessage | Overloaded.
Read |
ReadAll |
Update | Overloaded.
UpdateOrCreate |

Public Instance Constructors

HelpMessage Constructor Initializes a new instance of the HelpMessage class.

Public Instance Properties

CultureCode
Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Message
Url

Public Instance Methods

Create (inherited from Övning.Data.Util.PersistentObject) |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

HelpMessage Class | Övning.Domain Namespace


HelpMessage Methods

The methods of the HelpMessage class are listed below. For a complete list of HelpMessage class members, see the HelpMessage Members topic.

Public Static Methods

FetchMessage | Overloaded.
Read |
ReadAll |
Update | Overloaded.
UpdateOrCreate |

Public Instance Methods

Create (inherited from Övning.Data.Util.PersistentObject) |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) | Overloaded.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

HelpMessage Class | Övning.Domain Namespace


HelpMessage Properties

The properties of the HelpMessage class are listed below. For a complete list of HelpMessage class members, see the HelpMessage Members topic.

Public Instance Properties

CultureCode
Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Message
Url

See Also

HelpMessage Class | Övning.Domain Namespace


License Class

For a list of all members of this type, see License Members.

System.Object
PersistentObject
License

public class License : PersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

License Members | Övning.Domain Namespace


AnnualSubscriptionFee Property

An NDoc Documented Class Library

License.AnnualSubscriptionFee Property

public AnnualSubscriptionFee {get; set;}

See Also

License Class | Övning.Domain Namespace


License.Create Method

public override int Create();

See Also

License Class | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

License.Identifier Property

public Identifier {get; set;}

See Also

License Class | Övning.Domain Namespace


Name Property

An NDoc Documented Class Library

License.Name Property

public Name {get; set;}

See Also

License Class | Övning.Domain Namespace


PricePerLargeWarGame Property

An NDoc Documented Class Library

License.PricePerLargeWarGame Property

public PricePerLargeWarGame {get; set;}

See Also

License Class | Övning.Domain Namespace


PricePerSmallWarGame Property

An NDoc Documented Class Library

License.PricePerSmallWarGame Property

public PricePerSmallWarGame {get; set;}

See Also

License Class | Övning.Domain Namespace


PricePerSurvey Property

An NDoc Documented Class Library

License.PricePerSurvey Property

public PricePerSurvey {get; set;}

See Also

License Class | Övning.Domain Namespace


License.Read Method

public static License Read(
Int32 identifier
);

See Also

License Class | Övning.Domain Namespace


License.ReadAll Method

new public static IList<T> ReadAll();

See Also

License Class | Övning.Domain Namespace


Type Property

An NDoc Documented Class Library

License.Type Property

public Type {get; set;}

See Also

License Class | Övning.Domain Namespace


License Constructor

Overload List

Initializes a new instance of the License class.

public License();

public License(String,Int32,Int32,Int32,Int32);

See Also

License Class | Övning.Domain Namespace


License Constructor (String, Int32, Int32, Int32, Int32)

public License(
String name,
Int32 annualSubscriptionFee,
Int32 pricePerSurvey,
Int32 pricePerSmallWarGame,
Int32 pricePerBigWarGame
);

See Also

License Class | Övning.Domain Namespace | License Constructor Overload List


License Constructor ()

Initializes a new instance of the License class.

public License();

See Also

License Class | Övning.Domain Namespace | License Constructor Overload List


License Members

License overview

Public Static Methods

Read
ReadAll

Public Instance Constructors

License Overloaded. Initializes a new instance of the License class.

Public Instance Properties

AnnualSubscriptionFee
Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Name
PricePerLargeWarGame
PricePerSmallWarGame
PricePerSurvey
Type

Public Instance Methods

Create |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

License Class | Övning.Domain Namespace


License Methods

The methods of the License class are listed below. For a complete list of License class members, see the License Members topic.

Public Static Methods

Read
ReadAll

Public Instance Methods

Create |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

License Class | Övning.Domain Namespace


License Properties

The properties of the License class are listed below. For a complete list of License class members, see the License Members topic.

Public Instance Properties

AnnualSubscriptionFee
Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Name
PricePerLargeWarGame
PricePerSmallWarGame
PricePerSurvey
Type

See Also

License Class | Övning.Domain Namespace


LogEntry Class

Corresponds with the database table HCK

For a list of all members of this type, see LogEntry Members.

System.Object
PersistentObject
LogEntry

public class LogEntry : PersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

LogEntry Members | Övning.Domain Namespace


LogEntry.Create Method

Inserts a new LogEntry into the database and sets its Identifier with the autogenerated key

public override int Create();

Return Value

Integer

Remarks

See Also

LogEntry Class | Övning.Domain Namespace


ErrorCode Property

An NDoc Documented Class Library

LogEntry.ErrorCode Property

Unique identifier of the specific error.

public ErrorCode {get; set;}

Property Value

Remarks

See Also

LogEntry Class | Övning.Domain Namespace


ErrorMessage Property

An NDoc Documented Class Library

LogEntry.ErrorMessage Property

The Errormessage that goes with the log event.

public ErrorMessage {get; set;}

Property Value

Remarks

Do NOT try to set its Identifier directly, use ErrorCode() instead

See Also

LogEntry Class | Övning.Domain Namespace


ErrorMessageDescription Property

An NDoc Documented Class Library

LogEntry.ErrorMessageDescription Property

Returns the description of the errormessage

public ErrorMessageDescription {get;}

See Also

LogEntry Class | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

LogEntry.Identifier Property

Unique Identifier. Is autogenerated when inserting a new LogEntry into the database

public Identifier {get; set;}

Remarks

See Also

LogEntry Class | Övning.Domain Namespace


IPAddress Property

An NDoc Documented Class Library

LogEntry.IPAddress Property

IPAddress of the user that caused the event.

public IPAddress {get; set;}

Property Value

Remarks

See Also

LogEntry Class | Övning.Domain Namespace


Password Property

An NDoc Documented Class Library

LogEntry.Password Property

Password that was used to try to log in.

public Password {get; set;}

Property Value

Remarks

See Also

LogEntry Class | Övning.Domain Namespace


LogEntry.Read Method

Reads as specific log from the database, with key = Identifier

public static LogEntry Read(
Int32 identifier
);

Parameters

Int32

Return Value

LogEntry

Remarks

See Also

LogEntry Class | Övning.Domain Namespace


LogEntry.ReadAll Method

Reads all log events currently in the database

new public static IList<T> ReadAll();

Return Value

IList(Of LogEntry)

Remarks

See Also

LogEntry Class | Övning.Domain Namespace


Time Property

An NDoc Documented Class Library

LogEntry.Time Property

Time of the logging event.

public Time {get; set;}

Property Value

Remarks

See Also

LogEntry Class | Övning.Domain Namespace


Username Property

An NDoc Documented Class Library

LogEntry.Username Property

Username that was used to try to log in with.

public Username {get; set;}

Property Value

Remarks

See Also

LogEntry Class | Övning.Domain Namespace


LogEntry Constructor

Initializes a new instance of the LogEntry class.

public LogEntry();

See Also

LogEntry Class | Övning.Domain Namespace


LogEntry Members

LogEntry overview

Public Static Methods

Read | Reads as specific log from the database, with key = Identifier
ReadAll | Reads all log events currently in the database

Public Instance Constructors

LogEntry Constructor Initializes a new instance of the LogEntry class.

Public Instance Properties

ErrorCode | Unique identifier of the specific error.
ErrorMessage | The Errormessage that goes with the log event.
ErrorMessageDescription | Returns the description of the errormessage
Identifier | Unique Identifier. Is autogenerated when inserting a new LogEntry into the database
IPAddress | IPAddress of the user that caused the event.
Map (inherited from Övning.Data.Util.PersistentObject) |
Password | Password that was used to try to log in.
Time | Time of the logging event.
Username | Username that was used to try to log in with.

Public Instance Methods

Create | Inserts a new LogEntry into the database and sets its Identifier with the autogenerated key
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

LogEntry Class | Övning.Domain Namespace


LogEntry Methods

The methods of the LogEntry class are listed below. For a complete list of LogEntry class members, see the LogEntry Members topic.

Public Static Methods

Read | Reads as specific log from the database, with key = Identifier
ReadAll | Reads all log events currently in the database

Public Instance Methods

Create | Inserts a new LogEntry into the database and sets its Identifier with the autogenerated key
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

LogEntry Class | Övning.Domain Namespace


LogEntry Properties

The properties of the LogEntry class are listed below. For a complete list of LogEntry class members, see the LogEntry Members topic.

Public Instance Properties

ErrorCode | Unique identifier of the specific error.
ErrorMessage | The Errormessage that goes with the log event.
ErrorMessageDescription | Returns the description of the errormessage
Identifier | Unique Identifier. Is autogenerated when inserting a new LogEntry into the database
IPAddress | IPAddress of the user that caused the event.
Map (inherited from Övning.Data.Util.PersistentObject) |
Password | Password that was used to try to log in.
Time | Time of the logging event.
Username | Username that was used to try to log in with.

See Also

LogEntry Class | Övning.Domain Namespace


Organisation Class

An organisation organizes wargames

For a list of all members of this type, see Organisation Members.

System.Object
PersistentObject
Organisation

public class Organisation : PersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Corresponds with the ORG table in the Systemdatabase

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

Organisation Members | Övning.Domain Namespace


Address1 Property

An NDoc Documented Class Library

Organisation.Address1 Property

Address of the Organisation

public Address1 {get; set;}

See Also

Organisation Class | Övning.Domain Namespace


Address2 Property

An NDoc Documented Class Library

Organisation.Address2 Property

Secondary address of the organisation

public Address2 {get; set;}

Remarks

Optional

See Also

Organisation Class | Övning.Domain Namespace


City Property

An NDoc Documented Class Library

Organisation.City Property

City the orginisation is based in

public City {get; set;}

See Also

Organisation Class | Övning.Domain Namespace


Country Property

An NDoc Documented Class Library

Organisation.Country Property

Country the Organisation is based in

public Country {get; set;}

Remarks

Do NOT try to set its ID manually, use CountryID() instead

See Also

Organisation Class | Övning.Domain Namespace


CountryId Property

An NDoc Documented Class Library

Organisation.CountryId Property

Identifier of the Country the Organisation is based in

public CountryId {get; set;}

See Also

Organisation Class | Övning.Domain Namespace


Organisation.Create Method

Inserts the Organisation into the database after generating a random Licensenumber

public override int Create();

See Also

Organisation Class | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

Organisation.Identifier Property

Unique identifier, automatically generated when a new Organisation is inserted into the database.

public Identifier {get; set;}

Remarks

NOT used as key, OrganisationLicenceNumber is used instead

See Also

Organisation Class | Övning.Domain Namespace


LicenceNumber Property

An NDoc Documented Class Library

Organisation.LicenceNumber Property

Licencenumber of the Organisation. This number is unique.

public LicenceNumber {get; set;}

Remarks

Used as key. A folder with this name is generated when the organisation is created.

See Also

Organisation Class | Övning.Domain Namespace


LicenseType Property

An NDoc Documented Class Library

Organisation.LicenseType Property

Identifier of the LicenseType

public LicenseType {get; set;}

See Also

Organisation Class | Övning.Domain Namespace


Name Property

An NDoc Documented Class Library

Organisation.Name Property

Name of the Organisation

public Name {get; set;}

See Also

Organisation Class | Övning.Domain Namespace


Organisation.Read Method

Reads a specific orginisation from the database

public static Organisation Read(
String lic
);

Parameters

String
Licencenumber of the Organisation that will be read

Return Value

See Also

Organisation Class | Övning.Domain Namespace


Organisation.ReadAll Method

Reads all Organisations from the database

new public static IList<T> ReadAll();

Return Value

IList(Of Organisation)

See Also

Organisation Class | Övning.Domain Namespace


Status Property

An NDoc Documented Class Library

Organisation.Status Property

Status of the Organisation. Active (default) or Revoked

public Status {get; set;}

Remarks

Do NOT try to set its ID manually, use StatusID() instead

See Also

Organisation Class | Övning.Domain Namespace


StatusId Property

An NDoc Documented Class Library

Organisation.StatusId Property

Identifier of the Status of the Organisation

public StatusId {get; set;}

See Also

Organisation Class | Övning.Domain Namespace


Zipcode Property

An NDoc Documented Class Library

Organisation.Zipcode Property

Zip code of the organisation

public Zipcode {get; set;}

See Also

Organisation Class | Övning.Domain Namespace


Organisation Constructor

Initializes a new instance of the Organisation class.

public Organisation();

See Also

Organisation Class | Övning.Domain Namespace


Organisation Members

Organisation overview

Public Static Methods

Read | Reads a specific orginisation from the database
ReadAll | Reads all Organisations from the database

Public Instance Constructors

Organisation Constructor Initializes a new instance of the Organisation class.

Public Instance Properties

Address1 | Address of the Organisation
Address2 | Secondary address of the organisation
City | City the orginisation is based in
Country | Country the Organisation is based in
CountryId | Identifier of the Country the Organisation is based in
Identifier | Unique identifier, automatically generated when a new Organisation is inserted into the database.
LicenceNumber | Licencenumber of the Organisation. This number is unique.
LicenseType | Identifier of the LicenseType
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | Name of the Organisation
Status | Status of the Organisation. Active (default) or Revoked
StatusId | Identifier of the Status of the Organisation
Zipcode | Zip code of the organisation

Public Instance Methods

Create | Inserts the Organisation into the database after generating a random Licensenumber
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Organisation Class | Övning.Domain Namespace


Organisation Methods

The methods of the Organisation class are listed below. For a complete list of Organisation class members, see the Organisation Members topic.

Public Static Methods

Read | Reads a specific orginisation from the database
ReadAll | Reads all Organisations from the database

Public Instance Methods

Create | Inserts the Organisation into the database after generating a random Licensenumber
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Organisation Class | Övning.Domain Namespace


Organisation Properties

The properties of the Organisation class are listed below. For a complete list of Organisation class members, see the Organisation Members topic.

Public Instance Properties

Address1 | Address of the Organisation
Address2 | Secondary address of the organisation
City | City the orginisation is based in
Country | Country the Organisation is based in
CountryId | Identifier of the Country the Organisation is based in
Identifier | Unique identifier, automatically generated when a new Organisation is inserted into the database.
LicenceNumber | Licencenumber of the Organisation. This number is unique.
LicenseType | Identifier of the LicenseType
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | Name of the Organisation
Status | Status of the Organisation. Active (default) or Revoked
StatusId | Identifier of the Status of the Organisation
Zipcode | Zip code of the organisation

See Also

Organisation Class | Övning.Domain Namespace


PasswordQuestion Class

PasswordQuestions are can be answered to retrieve ones password. At registration a question can be selected, and an answer given. Later he same answer will need to be given to retrieve ones password.

For a list of all members of this type, see PasswordQuestion Members.

System.Object
PersistentObject
PasswordQuestion

public class PasswordQuestion : PersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

PasswordQuestion Members | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

PasswordQuestion.Identifier Property

Unique identifier of the PasswordQuestion. Automatically generated when a new PasswordQuestion is inserted into the database, which will never happen

public Identifier {get; set;}

See Also

PasswordQuestion Class | Övning.Domain Namespace


Question Property

An NDoc Documented Class Library

PasswordQuestion.Question Property

Name of the PasswordQuestion

public Question {get; set;}

See Also

PasswordQuestion Class | Övning.Domain Namespace


PasswordQuestion.Read Method

Reads a specific PasswordQuestion from the cached list of PasswordQuestions

public static PasswordQuestion Read(
Int32 id
);

Parameters

Int32
Identifier of the PasswordQuestion

Return Value

PasswordQuestion

See Also

PasswordQuestion Class | Övning.Domain Namespace


PasswordQuestion.ReadAll Method

Reads all PasswordQuestions from the database and caches the result. All future ReadAll()'s will return the cached list. Adding new PasswordQuestions to the database will require a restart of the application

new public static IList<T> ReadAll();

Return Value

IList(Of PasswordQuestion)

Remarks

See Also

PasswordQuestion Class | Övning.Domain Namespace


PasswordQuestion Constructor

Initializes a new instance of the PasswordQuestion class.

public PasswordQuestion();

See Also

PasswordQuestion Class | Övning.Domain Namespace


PasswordQuestion Members

PasswordQuestion overview

Public Static Methods

Read | Reads a specific PasswordQuestion from the cached list of PasswordQuestions
ReadAll | Reads all PasswordQuestions from the database and caches the result. All future ReadAll()'s will return the cached list. Adding new PasswordQuestions to the database will require a restart of the application

Public Instance Constructors

PasswordQuestion Constructor Initializes a new instance of the PasswordQuestion class.

Public Instance Properties

Identifier | Unique identifier of the PasswordQuestion. Automatically generated when a new PasswordQuestion is inserted into the database, which will never happen
Map (inherited from Övning.Data.Util.PersistentObject) |
Question | Name of the PasswordQuestion

Public Instance Methods

Create (inherited from Övning.Data.Util.PersistentObject) |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

PasswordQuestion Class | Övning.Domain Namespace


PasswordQuestion Methods

The methods of the PasswordQuestion class are listed below. For a complete list of PasswordQuestion class members, see the PasswordQuestion Members topic.

Public Static Methods

Read | Reads a specific PasswordQuestion from the cached list of PasswordQuestions
ReadAll | Reads all PasswordQuestions from the database and caches the result. All future ReadAll()'s will return the cached list. Adding new PasswordQuestions to the database will require a restart of the application

Public Instance Methods

Create (inherited from Övning.Data.Util.PersistentObject) |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

PasswordQuestion Class | Övning.Domain Namespace


PasswordQuestion Properties

The properties of the PasswordQuestion class are listed below. For a complete list of PasswordQuestion class members, see the PasswordQuestion Members topic.

Public Instance Properties

Identifier | Unique identifier of the PasswordQuestion. Automatically generated when a new PasswordQuestion is inserted into the database, which will never happen
Map (inherited from Övning.Data.Util.PersistentObject) |
Question | Name of the PasswordQuestion

See Also

PasswordQuestion Class | Övning.Domain Namespace


Question Class

Questions can exist on their own or be part of a Survey. When a Question is deleted all corresponding Questions will be removed from surveys that contained it.

For a list of all members of this type, see Question Members.

System.Object
PersistentObject
OrganisationBoundPersistentObject
Question

public class Question : OrganisationBoundPersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

Question Members | Övning.Domain Namespace


Answer Property

An NDoc Documented Class Library

Question.Answer Property

Answer, or answers delimited by #

public Answer {get; set;}

See Also

Question Class | Övning.Domain Namespace


Answers Property

An NDoc Documented Class Library

Question.Answers Property

Returns a list of answers to this question

public Answers {get;}

See Also

Question Class | Övning.Domain Namespace


Category Property

An NDoc Documented Class Library

Question.Category Property

Category

public Category {get; set;}

See Also

Question Class | Övning.Domain Namespace


CategoryId Property

An NDoc Documented Class Library

Question.CategoryId Property

Identifier of the Question's Category

public CategoryId {get; set;}

See Also

Question Class | Övning.Domain Namespace


Comments Property

An NDoc Documented Class Library

Question.Comments Property

Comments, whatever else you need to write.

public Comments {get; set;}

See Also

Question Class | Övning.Domain Namespace


Control Property

An NDoc Documented Class Library

Question.Control Property

Returns a control that represents this question.

public Control {get;}

See Also

Question Class | Övning.Domain Namespace


Question.ControlWithAnswer Method

public Control ControlWithAnswer(
IList<T> myAnswers
);

See Also

Question Class | Övning.Domain Namespace


Question.Create Method

Inserts a new Question into the database and returns the autogenerated identifier.

public override int Create();

Return Value

Integer

See Also

Question Class | Övning.Domain Namespace


Description Property

An NDoc Documented Class Library

Question.Description Property

Description of the Question. Describe the situation, conditions... etc.

public Description {get; set;}

See Also

Question Class | Övning.Domain Namespace


Question.GetAnswersFor Method

Returns answers for a certain control and type

public static IList<T> GetAnswersFor(
WebControl control,
String typeName
);

Parameters

WebControl
The control with the answers (e.g. selected checkboxlist)
String
The typename of the question(e.g. select)

Return Value

A list of answers that are selected in the control

See Also

Question Class | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

Question.Identifier Property

Unique Identifier. Is autogenerated when a new Question is inserted into the database

public Identifier {get; set;}

See Also

Question Class | Övning.Domain Namespace


QuestionText Property

An NDoc Documented Class Library

Question.QuestionText Property

The actual Question text. Do you agree?

public QuestionText {get; set;}

See Also

Question Class | Övning.Domain Namespace


Question.Read Method

Reads a specific question from the database

public static Question Read(
Int32 identifier
);

Parameters

Int32
Identifier of the question

Return Value

Question

See Also

Question Class | Övning.Domain Namespace


Question.ReadAll Method

Reads all Questions from the database

new public static IList<T> ReadAll();

Return Value

List(Of Question)

See Also

Question Class | Övning.Domain Namespace


Question.ReadQuestionsForSurvey Method

Reads all Questions that are linked to a specific Survey

public static IList<T> ReadQuestionsForSurvey(
Survey survey
);

Parameters

Survey
Identifier of the Survey

Return Value

IList(Of Question)

See Also

Question Class | Övning.Domain Namespace


Required Property

An NDoc Documented Class Library

Question.Required Property

Defines if the question has to be answerd by the user

public Required {get; set;}

See Also

Question Class | Övning.Domain Namespace


Title Property

An NDoc Documented Class Library

Question.Title Property

Title of the Question

public Title {get; set;}

See Also

Question Class | Övning.Domain Namespace


Type Property

An NDoc Documented Class Library

Question.Type Property

Type of the Question (eg. Radiobuttons, checkboxes, textfield...)

public Type {get; set;}

See Also

Question Class | Övning.Domain Namespace


TypeId Property

An NDoc Documented Class Library

Question.TypeId Property

Identifier of the Question's Type

public TypeId {get; set;}

See Also

Question Class | Övning.Domain Namespace


Question Constructor

Initializes a new instance of the Question class.

public Question();

See Also

Question Class | Övning.Domain Namespace


Question Members

Question overview

Public Static Methods

GetAnswersFor | Returns answers for a certain control and type
Read | Reads a specific question from the database
ReadAll | Reads all Questions from the database
ReadQuestionsForSurvey | Reads all Questions that are linked to a specific Survey

Public Instance Constructors

Question Constructor Initializes a new instance of the Question class.

Public Instance Properties

Answer | Answer, or answers delimited by #
Answers | Returns a list of answers to this question
Category | Category
CategoryId | Identifier of the Question's Category
Comments | Comments, whatever else you need to write.
Control | Returns a control that represents this question.
Description | Description of the Question. Describe the situation, conditions... etc.
Identifier | Unique Identifier. Is autogenerated when a new Question is inserted into the database
Map (inherited from Övning.Data.Util.PersistentObject) |
QuestionText | The actual Question text. Do you agree?
Required | Defines if the question has to be answerd by the user
Title | Title of the Question
Type | Type of the Question (eg. Radiobuttons, checkboxes, textfield...)
TypeId | Identifier of the Question's Type

Public Instance Methods

ControlWithAnswer |
Create | Inserts a new Question into the database and returns the autogenerated identifier.
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Question Class | Övning.Domain Namespace


Question Methods

The methods of the Question class are listed below. For a complete list of Question class members, see the Question Members topic.

Public Static Methods

GetAnswersFor | Returns answers for a certain control and type
Read | Reads a specific question from the database
ReadAll | Reads all Questions from the database
ReadQuestionsForSurvey | Reads all Questions that are linked to a specific Survey

Public Instance Methods

ControlWithAnswer |
Create | Inserts a new Question into the database and returns the autogenerated identifier.
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Question Class | Övning.Domain Namespace


Question Properties

The properties of the Question class are listed below. For a complete list of Question class members, see the Question Members topic.

Public Instance Properties

Answer | Answer, or answers delimited by #
Answers | Returns a list of answers to this question
Category | Category
CategoryId | Identifier of the Question's Category
Comments | Comments, whatever else you need to write.
Control | Returns a control that represents this question.
Description | Description of the Question. Describe the situation, conditions... etc.
Identifier | Unique Identifier. Is autogenerated when a new Question is inserted into the database
Map (inherited from Övning.Data.Util.PersistentObject) |
QuestionText | The actual Question text. Do you agree?
Required | Defines if the question has to be answerd by the user
Title | Title of the Question
Type | Type of the Question (eg. Radiobuttons, checkboxes, textfield...)
TypeId | Identifier of the Question's Type

See Also

Question Class | Övning.Domain Namespace


QuestionType Class

Corresponds with the CTL table in the organisation database

For a list of all members of this type, see QuestionType Members.

System.Object
PersistentObject
OrganisationBoundPersistentObject
QuestionType

public class QuestionType : OrganisationBoundPersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

QuestionType Members | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

QuestionType.Identifier Property

Unique Identifier. Is autogenerated when inserting a new QuestionType into the database

public Identifier {get; set;}

Remarks

See Also

QuestionType Class | Övning.Domain Namespace


Name Property

An NDoc Documented Class Library

QuestionType.Name Property

Name of the QuestionType

public Name {get; set;}

Remarks

See Also

QuestionType Class | Övning.Domain Namespace


QuestionType.Read Method

Reads a specific Questiontype from the cached list of QuestionTypes

public static QuestionType Read(
Int32 identifier
);

Parameters

Int32
key

Return Value

QuestionType

Remarks

Exceptions

Exception Type | Condition
ArgumentException | When no QuestionType with this identifier exists

See Also

QuestionType Class | Övning.Domain Namespace


QuestionType.ReadAll Method

Reads all Questiontypes from the database. Caches the result. All future ReadAll()'s will return the cached list. Adding new QuestionTypes to the database will require a restart of the application

new public static IList<T> ReadAll();

Return Value

IList(Of QuestionType)

Remarks

See Also

QuestionType Class | Övning.Domain Namespace


QuestionType Constructor

Initializes a new instance of the QuestionType class.

public QuestionType();

See Also

QuestionType Class | Övning.Domain Namespace


QuestionType Members

QuestionType overview

Public Static Methods

Read | Reads a specific Questiontype from the cached list of QuestionTypes
ReadAll | Reads all Questiontypes from the database. Caches the result. All future ReadAll()'s will return the cached list. Adding new QuestionTypes to the database will require a restart of the application

Public Instance Constructors

QuestionType Constructor Initializes a new instance of the QuestionType class.

Public Instance Properties

Identifier | Unique Identifier. Is autogenerated when inserting a new QuestionType into the database
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | Name of the QuestionType

Public Instance Methods

Create (inherited from OrganisationBoundPersistentObject) |
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

QuestionType Class | Övning.Domain Namespace


QuestionType Methods

The methods of the QuestionType class are listed below. For a complete list of QuestionType class members, see the QuestionType Members topic.

Public Static Methods

Read | Reads a specific Questiontype from the cached list of QuestionTypes
ReadAll | Reads all Questiontypes from the database. Caches the result. All future ReadAll()'s will return the cached list. Adding new QuestionTypes to the database will require a restart of the application

Public Instance Methods

Create (inherited from OrganisationBoundPersistentObject) |
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

QuestionType Class | Övning.Domain Namespace


QuestionType Properties

The properties of the QuestionType class are listed below. For a complete list of QuestionType class members, see the QuestionType Members topic.

Public Instance Properties

Identifier | Unique Identifier. Is autogenerated when inserting a new QuestionType into the database
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | Name of the QuestionType

See Also

QuestionType Class | Övning.Domain Namespace


Rank Class

For a list of all members of this type, see Rank Members.

System.Object
PersistentObject
Rank

public class Rank : PersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

Rank Members | Övning.Domain Namespace


AdminRank Property

An NDoc Documented Class Library

Rank.AdminRank Property

public static AdminRank {get;}

See Also

Rank Class | Övning.Domain Namespace


Rank.AssignableRanks Method

public static IList<T> AssignableRanks();

Return Value

All the ranks except the SU rank.

Remarks

Does not return the SU Rank!

See Also

Rank Class | Övning.Domain Namespace


Rank.Create Method

public override int Create();

See Also

Rank Class | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

Rank.Identifier Property

public Identifier {get; set;}

See Also

Rank Class | Övning.Domain Namespace


Name Property

An NDoc Documented Class Library

Rank.Name Property

public Name {get; set;}

See Also

Rank Class | Övning.Domain Namespace


ParticipantRank Property

An NDoc Documented Class Library

Rank.ParticipantRank Property

public static ParticipantRank {get;}

See Also

Rank Class | Övning.Domain Namespace


Rank.Read Method

public static Rank Read(
Int32 id
);

See Also

Rank Class | Övning.Domain Namespace


Rank.ReadAll Method

Reads all the ranks.

new public static IList<T> ReadAll();

See Also

Rank Class | Övning.Domain Namespace


SURank Property

An NDoc Documented Class Library

Rank.SURank Property

public static SURank {get;}

See Also

Rank Class | Övning.Domain Namespace


Rank Constructor

Initializes a new instance of the Rank class.

public Rank();

See Also

Rank Class | Övning.Domain Namespace


Rank Members

Rank overview

Public Static Properties

AdminRank
ParticipantRank
SURank

Public Static Methods

AssignableRanks |
Read |
ReadAll | Reads all the ranks.

Public Instance Constructors

Rank Constructor Initializes a new instance of the Rank class.

Public Instance Properties

Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Name

Public Instance Methods

Create |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Rank Class | Övning.Domain Namespace


Rank Methods

The methods of the Rank class are listed below. For a complete list of Rank class members, see the Rank Members topic.

Public Static Methods

AssignableRanks |
Read |
ReadAll | Reads all the ranks.

Public Instance Methods

Create |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Rank Class | Övning.Domain Namespace


Rank Properties

The properties of the Rank class are listed below. For a complete list of Rank class members, see the Rank Members topic.

Public Static Properties

AdminRank
ParticipantRank
SURank

Public Instance Properties

Identifier
Map (inherited from Övning.Data.Util.PersistentObject)
Name

See Also

Rank Class | Övning.Domain Namespace


Övning.Domain.Reporting

An NDoc Documented Class Library

Övning.Domain.Reporting Namespace

Namespace hierarchy

Classes

Class | Description
QuestionRepresentation |


QuestionRepresentation Class

For a list of all members of this type, see QuestionRepresentation Members.

System.Object
QuestionRepresentation

public class QuestionRepresentation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain.Reporting

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

QuestionRepresentation Members | Övning.Domain.Reporting Namespace


BarChart Property

An NDoc Documented Class Library

QuestionRepresentation.BarChart Property

public BarChart {get;}

See Also

QuestionRepresentation Class | Övning.Domain.Reporting Namespace


Chart Property

An NDoc Documented Class Library

QuestionRepresentation.Chart Property

public Chart {get;}

See Also

QuestionRepresentation Class | Övning.Domain.Reporting Namespace


PieChart Property

An NDoc Documented Class Library

QuestionRepresentation.PieChart Property

public PieChart {get;}

See Also

QuestionRepresentation Class | Övning.Domain.Reporting Namespace


QuestionRepresentation.WrapImageInEmfAndConvertToHex Method

public string WrapImageInEmfAndConvertToHex(
Image chart
);

See Also

QuestionRepresentation Class | Övning.Domain.Reporting Namespace


QuestionRepresentation Constructor

public QuestionRepresentation(
Survey mySurvey,
Question myQuestion,
IList<T> myAnswers,
Size mySize
);

See Also

QuestionRepresentation Class | Övning.Domain.Reporting Namespace


QuestionRepresentation Members

QuestionRepresentation overview

Public Instance Constructors

QuestionRepresentation Constructor

Public Instance Properties

BarChart
Chart
PieChart

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
WrapImageInEmfAndConvertToHex |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QuestionRepresentation Class | Övning.Domain.Reporting Namespace


QuestionRepresentation Methods

The methods of the QuestionRepresentation class are listed below. For a complete list of QuestionRepresentation class members, see the QuestionRepresentation Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
WrapImageInEmfAndConvertToHex |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QuestionRepresentation Class | Övning.Domain.Reporting Namespace


QuestionRepresentation Properties

The properties of the QuestionRepresentation class are listed below. For a complete list of QuestionRepresentation class members, see the QuestionRepresentation Members topic.

Public Instance Properties

BarChart
Chart
PieChart

See Also

QuestionRepresentation Class | Övning.Domain.Reporting Namespace


Hierarchy

System.Object
Övning.Domain.Reporting.QuestionRepresentation

See Also

Övning.Domain.Reporting Namespace


SecurityHandler Class

For a list of all members of this type, see SecurityHandler Members.

System.Object
SecurityHandler

public class SecurityHandler

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

SecurityHandler Members | Övning.Domain Namespace


SecurityHandler.ValidatePassword Method

public static bool ValidatePassword(
User myUser
);

See Also

SecurityHandler Class | Övning.Domain Namespace


SecurityHandler.ValidateUsername Method

public static bool ValidateUsername(
User myUser
);

See Also

SecurityHandler Class | Övning.Domain Namespace


SecurityHandler Members

SecurityHandler overview

Public Static Methods

ValidatePassword
ValidateUsername

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SecurityHandler Class | Övning.Domain Namespace


SecurityHandler Methods

The methods of the SecurityHandler class are listed below. For a complete list of SecurityHandler class members, see the SecurityHandler Members topic.

Public Static Methods

ValidatePassword
ValidateUsername

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SecurityHandler Class | Övning.Domain Namespace


Status Class

Defines the status of a user: Active or Revoked.

For a list of all members of this type, see Status Members.

System.Object
PersistentObject
Status

public class Status : PersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

Status Members | Övning.Domain Namespace


DefaultStatus Property

An NDoc Documented Class Library

Status.DefaultStatus Property

Returns the default status: the status for a user on creation

public static DefaultStatus {get;}

See Also

Status Class | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

Status.Identifier Property

The identifier of the satus

public Identifier {get; set;}

See Also

Status Class | Övning.Domain Namespace


Name Property

An NDoc Documented Class Library

Status.Name Property

The name of the status e.g. Active or Revoked.

public Name {get; set;}

See Also

Status Class | Övning.Domain Namespace


Status.Read Method

Reads a status from a cached list of statuses. This does not invoke a database roundtrip.

public static Status Read(
Int32 identifier
);

Parameters

Int32
The identifier of the status.

Return Value

The cached status.

Exceptions

Exception Type | Condition
ArgumentException | If there is no status with the specified identifier

See Also

Status Class | Övning.Domain Namespace


Status.ReadAll Method

Returns the cached statuses, this is to prevent database roundtrips. If the cache is nothing the statuses are read.

new public static IList<T> ReadAll();

Return Value

Remarks

See Also

Status Class | Övning.Domain Namespace


Status Constructor

Initializes a new instance of the Status class.

public Status();

See Also

Status Class | Övning.Domain Namespace


Status Members

Status overview

Public Static Properties

DefaultStatus Returns the default status: the status for a user on creation

Public Static Methods

Read | Reads a status from a cached list of statuses. This does not invoke a database roundtrip.
ReadAll | Returns the cached statuses, this is to prevent database roundtrips. If the cache is nothing the statuses are read.

Public Instance Constructors

Status Constructor Initializes a new instance of the Status class.

Public Instance Properties

Identifier | The identifier of the satus
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | The name of the status e.g. Active or Revoked.

Public Instance Methods

Create (inherited from Övning.Data.Util.PersistentObject) |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Status Class | Övning.Domain Namespace


Status Methods

The methods of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Static Methods

Read | Reads a status from a cached list of statuses. This does not invoke a database roundtrip.
ReadAll | Returns the cached statuses, this is to prevent database roundtrips. If the cache is nothing the statuses are read.

Public Instance Methods

Create (inherited from Övning.Data.Util.PersistentObject) |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Status Class | Övning.Domain Namespace


Status Properties

The properties of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Static Properties

DefaultStatus Returns the default status: the status for a user on creation

Public Instance Properties

Identifier | The identifier of the satus
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | The name of the status e.g. Active or Revoked.

See Also

Status Class | Övning.Domain Namespace


Survey Class

A survey has a couple of questions and belongs to a wargame

For a list of all members of this type, see Survey Members.

System.Object
PersistentObject
OrganisationBoundPersistentObject
Survey

public class Survey : OrganisationBoundPersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Corresponds with the SUR table in the oraganisationdatabase

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

Survey Members | Övning.Domain Namespace


Survey.AddQuestion Method

Adds a question to this Survey

public void AddQuestion(
Question question
);

Parameters

Question
The Question that will be added

Remarks

See Also

Survey Class | Övning.Domain Namespace


Survey.Create Method

Inserts a Survey into the database and sets its Identifier with the newly generated one

public override int Create();

Return Value

Integer

Remarks

Don't have to do anything with the returned integer

See Also

Survey Class | Övning.Domain Namespace


EndDate Property

An NDoc Documented Class Library

Survey.EndDate Property

public EndDate {get; set;}

See Also

Survey Class | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

Survey.Identifier Property

Unique Identifier. Autogenerated when a new Survey is inserted into the database.

public Identifier {get; set;}

See Also

Survey Class | Övning.Domain Namespace


Name Property

An NDoc Documented Class Library

Survey.Name Property

Name of the Survey

public Name {get; set;}

See Also

Survey Class | Övning.Domain Namespace


Questions Property

An NDoc Documented Class Library

Survey.Questions Property

All Questions in this Survey

public Questions {get;}

Remarks

ReadOnly

See Also

Survey Class | Övning.Domain Namespace


QuestionsNotInSurvey Property

An NDoc Documented Class Library

Survey.QuestionsNotInSurvey Property

All Questions that are not in this Survey

public QuestionsNotInSurvey {get;}

Property Value

Remarks

See Also

Survey Class | Övning.Domain Namespace


Survey.Read Method

Reads a specific Survey from the database

public static Survey Read(
Int32 identifier
);

Parameters

Int32
Identifier of the Survey to read

Return Value

Survey

See Also

Survey Class | Övning.Domain Namespace


Survey.ReadAll Method

Reads all Surveys from the database

new public static IList<T> ReadAll();

Return Value

List(Of Survey)

Remarks

See Also

Survey Class | Övning.Domain Namespace


Survey.ReadByWargameId Method

Reads all Surveys that belong to the given Wargame from the database.

public static IList<T> ReadByWargameId(
Int32 wargameId
);

Parameters

Int32
Id of the wargame that the Surveys should belong to

Return Value

IList(Of Survey)

See Also

Survey Class | Övning.Domain Namespace


Survey.ReadOpenSurveysByWargameId Method

public static IList<T> ReadOpenSurveysByWargameId(
Int32 wargameId
);

See Also

Survey Class | Övning.Domain Namespace


Survey.RemoveQuestion Method

Removes a Question from this Survey

public void RemoveQuestion(
Question question
);

Parameters

Question
The Question that will be removed

Remarks

See Also

Survey Class | Övning.Domain Namespace


StartDate Property

An NDoc Documented Class Library

Survey.StartDate Property

public StartDate {get; set;}

See Also

Survey Class | Övning.Domain Namespace


Survey.ToXML Method

public string ToXML();

See Also

Survey Class | Övning.Domain Namespace


Wargame Property

An NDoc Documented Class Library

Survey.Wargame Property

The Wargame this survey belongs to.

public Wargame {get; set;}

Property Value

Remarks

See Also

Survey Class | Övning.Domain Namespace


WargameId Property

An NDoc Documented Class Library

Survey.WargameId Property

Identifier of the Wargame this Survey belongs to

public WargameId {get; set;}

See Also

Survey Class | Övning.Domain Namespace


Survey Constructor

Initializes a new instance of the Survey class.

public Survey();

See Also

Survey Class | Övning.Domain Namespace


Survey Members

Survey overview

Public Static Methods

Read | Reads a specific Survey from the database
ReadAll | Reads all Surveys from the database
ReadByWargameId | Reads all Surveys that belong to the given Wargame from the database.
ReadOpenSurveysByWargameId |

Public Instance Constructors

Survey Constructor Initializes a new instance of the Survey class.

Public Instance Properties

EndDate |
Identifier | Unique Identifier. Autogenerated when a new Survey is inserted into the database.
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | Name of the Survey
Questions | All Questions in this Survey
QuestionsNotInSurvey | All Questions that are not in this Survey
StartDate |
Wargame | The Wargame this survey belongs to.
WargameId | Identifier of the Wargame this Survey belongs to

Public Instance Methods

AddQuestion | Adds a question to this Survey
Create | Inserts a Survey into the database and sets its Identifier with the newly generated one
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveQuestion | Removes a Question from this Survey
ToString (inherited from Object) | Returns a String that represents the current Object.
ToXML |
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Survey Class | Övning.Domain Namespace


Survey Methods

The methods of the Survey class are listed below. For a complete list of Survey class members, see the Survey Members topic.

Public Static Methods

Read | Reads a specific Survey from the database
ReadAll | Reads all Surveys from the database
ReadByWargameId | Reads all Surveys that belong to the given Wargame from the database.
ReadOpenSurveysByWargameId |

Public Instance Methods

AddQuestion | Adds a question to this Survey
Create | Inserts a Survey into the database and sets its Identifier with the newly generated one
Delete (inherited from OrganisationBoundPersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveQuestion | Removes a Question from this Survey
ToString (inherited from Object) | Returns a String that represents the current Object.
ToXML |
Update (inherited from OrganisationBoundPersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

Survey Class | Övning.Domain Namespace


Survey Properties

The properties of the Survey class are listed below. For a complete list of Survey class members, see the Survey Members topic.

Public Instance Properties

EndDate |
Identifier | Unique Identifier. Autogenerated when a new Survey is inserted into the database.
Map (inherited from Övning.Data.Util.PersistentObject) |
Name | Name of the Survey
Questions | All Questions in this Survey
QuestionsNotInSurvey | All Questions that are not in this Survey
StartDate |
Wargame | The Wargame this survey belongs to.
WargameId | Identifier of the Wargame this Survey belongs to

See Also

Survey Class | Övning.Domain Namespace


User Class

Corresponds with the USR table in the database

For a list of all members of this type, see User Members.

System.Object
PersistentObject
User

public class User : PersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Corresponds with the USR table in the System database. When a user is deleted, corresponding participants will allso be removed from Wargames

Requirements

Namespace: Övning.Domain

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

User Members | Övning.Domain Namespace


BottomMargin Property

An NDoc Documented Class Library

User.BottomMargin Property

public BottomMargin {get; set;}

See Also

User Class | Övning.Domain Namespace


User.Create Method

public override int Create();

See Also

User Class | Övning.Domain Namespace


Email Property

An NDoc Documented Class Library

User.Email Property

public Email {get; set;}

See Also

User Class | Övning.Domain Namespace


User.Exists Method (String)

Checks if a User with this username exists

public static bool Exists(
String userName
);

See Also

User Class | Övning.Domain Namespace | User.Exists Overload List


User.Exists Method (String, String)

public static bool Exists(
String userName,
String password
);

See Also

User Class | Övning.Domain Namespace | User.Exists Overload List


Exists Method

An NDoc Documented Class Library

User.Exists Method

Checks if a User with this username exists

Overload List

Checks if a User with this username exists

public static bool Exists(String);

public static bool Exists(String,String);

See Also

User Class | Övning.Domain Namespace


FailedPasswordAnswerAttempts Property

An NDoc Documented Class Library

User.FailedPasswordAnswerAttempts Property

public FailedPasswordAnswerAttempts {get; set;}

See Also

User Class | Övning.Domain Namespace


FailedPasswordAttempts Property

An NDoc Documented Class Library

User.FailedPasswordAttempts Property

public FailedPasswordAttempts {get; set;}

See Also

User Class | Övning.Domain Namespace


User.FindByOrganisation Method

public static IList<T> FindByOrganisation();

See Also

User Class | Övning.Domain Namespace


User.FindByUsername Method

public static User FindByUsername(
String username
);

See Also

User Class | Övning.Domain Namespace


Identifier Property

An NDoc Documented Class Library

User.Identifier Property

Username of the User

public Identifier {get; set;}

Remarks

See Also

User Class | Övning.Domain Namespace


Language Property

An NDoc Documented Class Library

User.Language Property

public Language {get; set;}

See Also

User Class | Övning.Domain Namespace


LastLogin Property

An NDoc Documented Class Library

User.LastLogin Property

public LastLogin {get; set;}

See Also

User Class | Övning.Domain Namespace


LeftMargin Property

An NDoc Documented Class Library

User.LeftMargin Property

public LeftMargin {get; set;}

See Also

User Class | Övning.Domain Namespace


User.Login Method

Logs this user in by creating a cookie and adding it to the httpresponse

public void Login(
HttpResponse response
);

Parameters

HttpResponse
The httpresponse to add the cookie to

Remarks

Has to be used in a httpcontext

See Also

User Class | Övning.Domain Namespace


Organisation Property

An NDoc Documented Class Library

User.Organisation Property

public Organisation {get; set;}

See Also

User Class | Övning.Domain Namespace


OrganisationLicenseNumber Property

An NDoc Documented Class Library

User.OrganisationLicenseNumber Property

public OrganisationLicenseNumber {get; set;}

See Also

User Class | Övning.Domain Namespace


Password Property

An NDoc Documented Class Library

User.Password Property

Password of the User

public Password {get; set;}

Remarks

See Also

User Class | Övning.Domain Namespace


PasswordAnswer Property

An NDoc Documented Class Library

User.PasswordAnswer Property

public PasswordAnswer {get; set;}

See Also

User Class | Övning.Domain Namespace


PasswordQuestion Property

An NDoc Documented Class Library

User.PasswordQuestion Property

public PasswordQuestion {get; set;}

See Also

User Class | Övning.Domain Namespace


PasswordQuestionId Property

An NDoc Documented Class Library

User.PasswordQuestionId Property

public PasswordQuestionId {get; set;}

See Also

User Class | Övning.Domain Namespace


Rank Property

An NDoc Documented Class Library

User.Rank Property

public Rank {get; set;}

See Also

User Class | Övning.Domain Namespace


RankId Property

An NDoc Documented Class Library

User.RankId Property

public RankId {get; set;}

See Also

User Class | Övning.Domain Namespace


User.Read Method

public static User Read(
Int32 identifier
);

See Also

User Class | Övning.Domain Namespace


User.ReadAll Method

new public static IList<T> ReadAll();

See Also

User Class | Övning.Domain Namespace


RightMargin Property

An NDoc Documented Class Library

User.RightMargin Property

public RightMargin {get; set;}

See Also

User Class | Övning.Domain Namespace


Status Property

An NDoc Documented Class Library

User.Status Property

public Status {get; set;}

See Also

User Class | Övning.Domain Namespace


StatusId Property

An NDoc Documented Class Library

User.StatusId Property

public StatusId {get; set;}

See Also

User Class | Övning.Domain Namespace


TopMargin Property

An NDoc Documented Class Library

User.TopMargin Property

public TopMargin {get; set;}

See Also

User Class | Övning.Domain Namespace


Username Property

An NDoc Documented Class Library

User.Username Property

Username of the User

public Username {get; set;}

Remarks

See Also

User Class | Övning.Domain Namespace


User Constructor

Initializes a new instance of the User class.

public User();

See Also

User Class | Övning.Domain Namespace


User Members

User overview

Public Static Methods

Exists | Overloaded. Checks if a User with this username exists
FindByOrganisation |
FindByUsername |
Read |
ReadAll |

Public Instance Constructors

User Constructor Initializes a new instance of the User class.

Public Instance Properties

BottomMargin |
Email |
FailedPasswordAnswerAttempts |
FailedPasswordAttempts |
Identifier | Username of the User
Language |
LastLogin |
LeftMargin |
Map (inherited from Övning.Data.Util.PersistentObject) |
Organisation |
OrganisationLicenseNumber |
Password | Password of the User
PasswordAnswer |
PasswordQuestion |
PasswordQuestionId |
Rank |
RankId |
RightMargin |
Status |
StatusId |
TopMargin |
Username | Username of the User

Public Instance Methods

Create |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Login | Logs this user in by creating a cookie and adding it to the httpresponse
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

User Class | Övning.Domain Namespace


User Methods

The methods of the User class are listed below. For a complete list of User class members, see the User Members topic.

Public Static Methods

Exists | Overloaded. Checks if a User with this username exists
FindByOrganisation |
FindByUsername |
Read |
ReadAll |

Public Instance Methods

Create |
Delete (inherited from Övning.Data.Util.PersistentObject) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Login | Logs this user in by creating a cookie and adding it to the httpresponse
ToString (inherited from Object) | Returns a String that represents the current Object.
Update (inherited from Övning.Data.Util.PersistentObject) |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

User Class | Övning.Domain Namespace


User Properties

The properties of the User class are listed below. For a complete list of User class members, see the User Members topic.

Public Instance Properties

BottomMargin |
Email |
FailedPasswordAnswerAttempts |
FailedPasswordAttempts |
Identifier | Username of the User
Language |
LastLogin |
LeftMargin |
Map (inherited from Övning.Data.Util.PersistentObject) |
Organisation |
OrganisationLicenseNumber |
Password | Password of the User
PasswordAnswer |
PasswordQuestion |
PasswordQuestionId |
Rank |
RankId |
RightMargin |
Status |
StatusId |
TopMargin |
Username | Username of the User

See Also

User Class | Övning.Domain Namespace


Övning.Domain.Util

An NDoc Documented Class Library

Övning.Domain.Util Namespace

Namespace hierarchy

Classes

Class | Description
OrganisationBoundPersistentObject |
ÖvningException |
ÖvningPrincipal |
RandomStringGenrator |
ResourceReader | Reads values out of the resource.


OrganisationBoundPersistentObject Class

For a list of all members of this type, see OrganisationBoundPersistentObject Members.

System.Object
PersistentObject
OrganisationBoundPersistentObject
Derived types

public class OrganisationBoundPersistentObject : PersistentObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain.Util

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

OrganisationBoundPersistentObject Members | Övning.Domain.Util Namespace


OrganisationBoundPersistentObject.Create Method

public override int Create();

See Also

OrganisationBoundPersistentObject Class | Övning.Domain.Util Namespace


OrganisationBoundPersistentObject.Delete Method

public override void Delete();

See Also

OrganisationBoundPersistentObject Class | Övning.Domain.Util Namespace


OrganisationBoundPersistentObject.Exists Method

new protected static bool <T>Exists(
PersistentObject objectToCheck
); where T: DefaultConstructorConstraint, PersistentObject

See Also

OrganisationBoundPersistentObject Class | Övning.Domain.Util Namespace


OrganisationLicenseNumber Property

An NDoc Documented Class Library

OrganisationBoundPersistentObject.OrganisationLicenseNumber Property

protected static OrganisationLicenseNumber {get;}

See Also

OrganisationBoundPersistentObject Class | Övning.Domain.Util Namespace


OrganisationBoundPersistentObject.Read Method

protected static OrganisationBoundPersistentObject <T>Read(
OrganisationBoundPersistentObject objectToRead
); where T: DefaultConstructorConstraint, OrganisationBoundPersistentObject

See Also

OrganisationBoundPersistentObject Class | Övning.Domain.Util Namespace


OrganisationBoundPersistentObject.ReadAll Method

new protected static IList<T> <T>ReadAll(); where T: DefaultConstructorConstraint, OrganisationBoundPersistentObject

See Also

OrganisationBoundPersistentObject Class | Övning.Domain.Util Namespace


OrganisationBoundPersistentObject.Update Method

public override void Update();

See Also

OrganisationBoundPersistentObject Class | Övning.Domain.Util Namespace


OrganisationBoundPersistentObject Constructor

Initializes a new instance of the OrganisationBoundPersistentObject class.

public OrganisationBoundPersistentObject();

See Also

OrganisationBoundPersistentObject Class | Övning.Domain.Util Namespace


OrganisationBoundPersistentObject Hierarchy

System.Object
PersistentObject
OrganisationBoundPersistentObject
Answer
Category
Document
DocumentType
Participant
ParticipantRole
WarGame
WarGameStatus
Question
QuestionType
Survey

See Also

OrganisationBoundPersistentObject Class | OrganisationBoundPersistentObject Members | Övning.Domain.Util Namespace


OrganisationBoundPersistentObject Members

OrganisationBoundPersistentObject overview

Protected Static Properties

OrganisationLicenseNumber

Protected Static Methods

Exists
Read
ReadAll

Public Instance Constructors

OrganisationBoundPersistentObject Constructor Initializes a new instance of the OrganisationBoundPersistentObject class.

Public Instance Properties

Map (inherited from Övning.Data.Util.PersistentObject)

Public Instance Methods

Create |
Delete |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

OrganisationBoundPersistentObject Class | Övning.Domain.Util Namespace


OrganisationBoundPersistentObject Methods

The methods of the OrganisationBoundPersistentObject class are listed below. For a complete list of OrganisationBoundPersistentObject class members, see the OrganisationBoundPersistentObject Members topic.

Protected Static Methods

Exists
Read
ReadAll

Public Instance Methods

Create |
Delete |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Update |

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetDirty (inherited from Övning.Data.Util.PersistentObject) |

See Also

OrganisationBoundPersistentObject Class | Övning.Domain.Util Namespace


OrganisationBoundPersistentObject Properties

The properties of the OrganisationBoundPersistentObject class are listed below. For a complete list of OrganisationBoundPersistentObject class members, see the OrganisationBoundPersistentObject Members topic.

Protected Static Properties

OrganisationLicenseNumber

Public Instance Properties

Map (inherited from Övning.Data.Util.PersistentObject)

See Also

OrganisationBoundPersistentObject Class | Övning.Domain.Util Namespace


RandomStringGenrator Class

For a list of all members of this type, see RandomStringGenrator Members.

System.Object
RandomStringGenrator

public class RandomStringGenrator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain.Util

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

RandomStringGenrator Members | Övning.Domain.Util Namespace


CaptchaString Property

An NDoc Documented Class Library

RandomStringGenrator.CaptchaString Property

public CaptchaString {get;}

See Also

RandomStringGenrator Class | Övning.Domain.Util Namespace


Password Property

An NDoc Documented Class Library

RandomStringGenrator.Password Property

public Password {get;}

See Also

RandomStringGenrator Class | Övning.Domain.Util Namespace


RandomString Property

An NDoc Documented Class Library

RandomStringGenrator.RandomString Property

public RandomString {get;}

See Also

RandomStringGenrator Class | Övning.Domain.Util Namespace


RandomStringGenrator Constructor

Initializes a new instance of the RandomStringGenrator class.

Overload List

Initializes a new instance of the RandomStringGenrator class.

public RandomStringGenrator();

public RandomStringGenrator(String);

See Also

RandomStringGenrator Class | Övning.Domain.Util Namespace


RandomStringGenrator Constructor ()

Initializes a new instance of the RandomStringGenrator class.

public RandomStringGenrator();

See Also

RandomStringGenrator Class | Övning.Domain.Util Namespace | RandomStringGenrator Constructor Overload List


RandomStringGenrator Constructor (String)

public RandomStringGenrator(
String passwordFilePath
);

See Also

RandomStringGenrator Class | Övning.Domain.Util Namespace | RandomStringGenrator Constructor Overload List


RandomStringGenrator Members

RandomStringGenrator overview

Public Instance Constructors

RandomStringGenrator Overloaded. Initializes a new instance of the RandomStringGenrator class.

Public Instance Properties

CaptchaString
Password
RandomString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RandomStringGenrator Class | Övning.Domain.Util Namespace


RandomStringGenrator Properties

The properties of the RandomStringGenrator class are listed below. For a complete list of RandomStringGenrator class members, see the RandomStringGenrator Members topic.

Public Instance Properties

CaptchaString
Password
RandomString

See Also

RandomStringGenrator Class | Övning.Domain.Util Namespace


ResourceReader Class

Reads values out of the resource.

For a list of all members of this type, see ResourceReader Members.

System.Object
ResourceReader

public class ResourceReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain.Util

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

ResourceReader Members | Övning.Domain.Util Namespace


ResourceReader.GetString Method

Reads a string out of the recource file.

public static string GetString(
String recourceName
);

Parameters

String
The name of the recource

Return Value

The value of the recource

See Also

ResourceReader Class | Övning.Domain.Util Namespace


ResourceReader Members

ResourceReader overview

Public Static Methods

GetString Reads a string out of the recource file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceReader Class | Övning.Domain.Util Namespace


ResourceReader Methods

The methods of the ResourceReader class are listed below. For a complete list of ResourceReader class members, see the ResourceReader Members topic.

Public Static Methods

GetString Reads a string out of the recource file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ResourceReader Class | Övning.Domain.Util Namespace


ÖvningException Class

For a list of all members of this type, see ÖvningException Members.

System.Object
Exception
ÖvningException

public class ÖvningException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain.Util

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

ÖvningException Members | Övning.Domain.Util Namespace


ÖvningException Constructor

Overload List

Initializes a new instance of the ÖvningException class.

public ÖvningException();

protected ÖvningException(SerializationInfo,StreamingContext);

public ÖvningException(String);

public ÖvningException(String,Exception);

See Also

ÖvningException Class | Övning.Domain.Util Namespace


ÖvningException Constructor (String)

public ÖvningException(
String message
);

See Also

ÖvningException Class | Övning.Domain.Util Namespace | ÖvningException Constructor Overload List


ÖvningException Constructor ()

Initializes a new instance of the ÖvningException class.

public ÖvningException();

See Also

ÖvningException Class | Övning.Domain.Util Namespace | ÖvningException Constructor Overload List


ÖvningException Constructor (String, Exception)

public ÖvningException(
String message,
Exception foutjeh
);

See Also

ÖvningException Class | Övning.Domain.Util Namespace | ÖvningException Constructor Overload List


ÖvningException Constructor (SerializationInfo, StreamingContext)

protected ÖvningException(
SerializationInfo serializationInfo,
StreamingContext streamingContext
);

See Also

ÖvningException Class | Övning.Domain.Util Namespace | ÖvningException Constructor Overload List


ÖvningException Members

ÖvningException overview

Public Instance Constructors

ÖvningException Overloaded. Initializes a new instance of the ÖvningException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

ÖvningException Overloaded. Initializes a new instance of the ÖvningException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ÖvningException Class | Övning.Domain.Util Namespace


ÖvningPrincipal Class

For a list of all members of this type, see ÖvningPrincipal Members.

System.Object
GenericPrincipal
ÖvningPrincipal

public class ÖvningPrincipal : GenericPrincipal

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Övning.Domain.Util

Assembly: Övning.Domain (in Övning.Domain.dll)

See Also

ÖvningPrincipal Members | Övning.Domain.Util Namespace


OrganisationLicenseNumber Property

An NDoc Documented Class Library

ÖvningPrincipal.OrganisationLicenseNumber Property

public OrganisationLicenseNumber {get;}

See Also

ÖvningPrincipal Class | Övning.Domain.Util Namespace


UserIdentifier Property

An NDoc Documented Class Library

ÖvningPrincipal.UserIdentifier Property

public UserIdentifier {get;}

See Also

ÖvningPrincipal Class | Övning.Domain.Util Namespace


ÖvningPrincipal Constructor

public ÖvningPrincipal(
IIdentity identity,
String[] roles,
String organisationLicenseNumber,
Int32 userIdentifier
);

See Also

ÖvningPrincipal Class | Övning.Domain.Util Namespace


ÖvningPrincipal Members

ÖvningPrincipal overview

Public Instance Constructors

ÖvningPrincipal Constructor

Public Instance Properties

Identity (inherited from GenericPrincipal) | Gets the GenericIdentity of the user represented by the current GenericPrincipal.
OrganisationLicenseNumber |
UserIdentifier |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsInRole (inherited from GenericPrincipal) | Determines whether the current GenericPrincipal belongs to the specified role.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ÖvningPrincipal Class | Övning.Domain.Util Namespace


ÖvningPrincipal Properties

The properties of the ÖvningPrincipal class are listed below. For a complete list of ÖvningPrincipal class members, see the ÖvningPrincipal Members topic.

Public Instance Properties

Identity (inherited from GenericPrincipal) | Gets the GenericIdentity of the user represented by the current GenericPrincipal.
OrganisationLicenseNumber |
UserIdentifier |

See Also

ÖvningPrincipal Class | Övning.Domain.Util Namespace


Hierarchy

System.Object
Övning.Data.Util.PersistentObject
Övning.Domain.Util.OrganisationBoundPersistentObject
Övning.Domain.Util.RandomStringGenrator
Övning.Domain.Util.ResourceReader
System.Exception ---- System.Runtime.Serialization.ISerializable
Övning.Domain.Util.ÖvningException
System.Security.Principal.GenericPrincipal ---- System.Security.Principal.IPrincipal
Övning.Domain.Util.ÖvningPrincipal

See Also

Övning.Domain.Util Namespace


Hierarchy

System.Object
Övning.Data.Util.PersistentObject
Övning.Domain.Country
Övning.Domain.ErrorMessage
Övning.Domain.HelpMessage
Övning.Domain.License
Övning.Domain.LogEntry
Övning.Domain.Organisation
Övning.Domain.PasswordQuestion
Övning.Domain.Rank
Övning.Domain.Status
Övning.Domain.User
Övning.Domain.Util.OrganisationBoundPersistentObject
Övning.Domain.Answer
Övning.Domain.Category
Övning.Domain.Question
Övning.Domain.QuestionType
Övning.Domain.Survey
Övning.Domain.SecurityHandler

See Also

Övning.Domain Namespace